MCPE的官方服务器

前不久弃坑的MCPE服务器(其实也有一段时间了)还没有彻底凉掉,现在MCPE在1.6.1.0的Android版本中写到MCPE官方推出了官方PE版服务器alpha,而且同时支持Windows和Linux(微软是不是挖到矿了突然良心),然后今天早上欢欢喜喜的上了minecraft.net去找,结果发现了这个,,

大大的Ubuntu,,满满的歧视CentOS啊,然后我觉得反正都是Linux,那就搞搞吧,,然后就开始了3个小时的折腾,,,

下载下来直接按照他说的运行,,提示缺libssl.so.1.0.0,然后现在垃圾s3上的是1.0.1还有更高的版本,,找了半天没找着老版,,然后就想了想,高版可能兼容低版,然后就把1.0.2复制过来重命名了一下,然后那个libcrypto.so.1.0.0也是这么弄的,,弄到最后不报缺少文件了,,,开始说libstdc++.so.6不够版本(GLIBC版本不够)也就是说,s3上的gcc的版本不够,,看了一眼,是4.8.5,而且是yum的最新版,然而deepin上的是4.9.3(我,,,)而且我不想重新编译,所以就开始从deepin上抠库,,到最后把缺的库抠完了,只报一个错——“Segment Fault”,,GG。

搁置了一会我又想,不能就这么放弃啊,在deepin上瞬间启动成功,,,虽然s3内存小负载高,我可以跑个Ubuntu的虚拟机啊,然后就想到了docker(虽然我并不怎么会用),然后就用docker整了一个Ubuntu(才40MiB???),然后apt-get也不能用,我也没有想让他占太多储存空间,所以就决定继续抠库,,,然后竟然缺这么多????

嘛,虽然非常麻烦点,但是还是成功的搭建起来了,拥有MCPE的全部功能,需要1.6.1.0的客户端(iOS1.6.0/1.6.2也可以加入)

发布者:Tabing010102

???

留下评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据